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Testing Your Icon or Cursor

IconForge is a graphics utility which is optimized for

creating icons, cursors or small images which can be

used in other projects (such as images to be used as

background wallpaper tiles). Some of the features

described in this handbook may vary slightly or be

unavailable, depending on which IconForge and

Windows versions you use (e.g., 16-bit or 32-bit).

Opening a New Editing Window

To edit an existing icon or cursor, or to import an

image from another file, use the Open function from

the File menu.

To create a new icon or cursor, first select the New

function from the File menu and then click on the

New Icon option. You will be asked to select a size

for the new image. Common Windows icon sizes
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include 16x16, 32x32, 48x48, 64x64 and 72x72. The

icons can use 2 colors, 16 colors, 256 colors or

16-million colors, although 16 colors and 256 colors

are standard for most uses. The standard  size for

Windows cursors and animated cursors is 32x32. If

you want a smaller sized cursor, fill the unused area

with transparent pixels.

Icons, and other bitmap images are measured in

“pixels.” A pixel is equivalent to a single dot on your

screen. A pixel is the smallest unit used for the

screen resolution being displayed.

Once you have selected the existing icon or chosen

the size for a new icon, an editing window will be
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displayed on  your screen, along with a bar at the

bottom of IconForge which contains painting tools

and color controls (see illustration next page).

Æ

Notes: Some Windows versions do not properly display

icons or cursors which contain more than 256 colors, so

you should avoid saving 16-million color icons unless

you are certain that this resolution is supported by the

version of Windows on which it will be used. Also, the

final display size is determined by the user’s Windows

settings or by the program in which it is used. Windows

will stretch non-standard sized icons to fit the size

specified in the user’s settings. For most Windows

versions, the icon size is set by going to the Windows

Control Panel, selecting the Display icon, going to its

Appearance tab, then selecting Icon from the Item list.

Cursors can contain a “Hot Spot” on the image which

activates items when clicked (e.g., on an arrow-shaped

cursor, the point of the arrow is usually the hot spot).

By default, this is set to the upper/left corner. However,

you can designate any pixel as the hot spot either by

clicking on the Options menu and choosing Set Cursor

Hot Spot, or by clicking twice on the Color Sampler tool

and choosing the Set Cursor Hot Spot selector.

Using the Tools

Creating or editing an icon is as easy as selecting a

tool from the tool bar at the bottom of the editing

screen, and then dragging that tool across the

editing window to draw a line, select an area, etc.

Most tools have multiple options or variations. You

can choose from among the options by clicking twice

on the tool (e.g., clicking twice on the Eraser tool

allows you to choose between a normal eraser, and

an eraser which replaces one color with a second

color).
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To select a region of your image, use the Scissors tool

to surround the area. Once you have selected a

region, i t may be copied, dragged to another

location (or moved with the Nudge tool), etc.

On the left side of the editing window, you will find

an actual-size preview for the icon or cursor being

edited, plus controls for magnifying the image to

edit fine details, etc. If you have a question about

what a particular control does, simply click on the

“?” icon for an explanation from the Help file.

To select colors for with which to paint, simply click

on a brush tool, click on a color from the Color

Palette, then click or drag the tool across the editing

area. You may load colors onto both the left and right

mouse buttons simply by clicking on the Color

Palette using those buttons.

Editing Windows

Images are displayed within individual editing

windows (see illustration on next page). You may

copy and paste between these windows, or even

open multiple copies of the same file.
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On the left side of each editing window you will see

a preview window which shows the icon or cursor at

its actual size. Below this is a Magnify control which

allows you to zoom in to edit fine details. Use the

binoculars icon to Test your icon or cursor with a

variety of backgrounds and controls. The green “+”

icon is used to add the current image to any opened

multi-resolution or animation window.

Making Transparent Areas

Use your Brush or Fill tools to mark areas which will

become transparent when the icon or cursor is

displayed. To  do this,  first select the Transparent

Paint button  next to  the tool bar’s Color Palette.

W h e n p a i n t i n g w i th Transparent Paint, e a c h

transparent pixel in the image will contain a small

dot in the center.

You can also designate areas which will reverse the

colors which lie under the icon or cursor. To do this,
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first select the Inverse Paint from the palette. Each

inverse pixel in the image will contain a slash

through it. Inverse areas are very useful when

des ign ing cursors , s ince no mat ter what the

background, you are assured that these areas of the

cursor (or icon) will be shown using contrasting

colors.

Æ

Notes: To see the effects of your transparent and

inverse areas, click on the Test button (the binoculars

icon) in the editing window.

The color underneath the transparent and inverse pixels

is for display purposes. These colors are not present in

the final icon or cursor. You may select another Preview

color by going to the Options menu and selecting Set

Preferences. You may wish to choose a color which is

close to the color of the background on which the icon

will  usually be displayed. When  saving an image as

either .GIF or .PNG graphic formats, you will be given

the option to designate all areas containing the

Transparent Preview Color as transparent in these

images.

Improper display of transparent or inverse areas can be

caused by the following:

— the icon is being scaled by Windows to a different

size. This could be because your icon is not a standard

16x16 or 32x32 size, or because Windows is  set  to

display icons at an odd size.

Transparent Paint

Inverse Paint

Tool Bar

10 - Creating Basic Icons & Cursors



— the video driver for the display is bad. Visit the video

card manufacturer’s web site to see if an updated driver

is available.

— the icon contains 16-million colors and is being

shown on a Windows NT or 2000 system. There is a bug

in these two Windows versions which can prevent the

display of icons which contain more than 256 colors.

— the Windows icon cache is corrupted. To fix this,

either go to the Edit menu and choose the Rebuild

Windows Icon Cache option, or click on the Edit/Change

Windows System Icons option to launch the ActivIcons

utility (it has more options for repairing the cache).

Applying Effects

IconForge contains an assortment of special Effects

filters. To apply a filter, first use the Scissors tool to

select an area of the image (you do not need to do

this if you want the effect to be applied to the entire

image). Next, go to the Effects menu and select the

filter you wish to use.
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On the left side of the Effects window, you will see

a list of all available filters from which you may

select. As you click on each filter, a preview at the

top of the list will give you a rough idea of how the

filter will affect your image.

In the center of the window are the controls for the

filter being used. The right side of the window

displays your image.

Once you have adjusted the controls for a filter, click

the Apply button at the bottom of the window. This

will update the image shown on the right side. If you

are satisfied with the effect, click OK to return to

editing. If you would like to make adjustment to the

filter controls, click the Undo button to return the

image to its previous state.

Æ

Note: Some special Effects need to blend adjacent

pixels. The transparent or inverse properties may be

blended away during these operations. You can use the

Fill tools to restore these attributes should this occur.

About Color Palettes

Most icons which you will create will have a limited

“palette” of colors. Depending on which resolution

you are using, the palette will contain either 2, 16 or

256 colors.

Selecting Colors

The current palette of colors is displayed on the tool

bar. You can click on the palette using either your

Palette: Icon Color Depth at 256 Colors
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left or right mouse button. This will load the color

you selected onto that mouse button. You will now

have 2 colors with which to paint, and you switch

between colors simply by changing mouse buttons.

You  can  select a color directly from the image by

using the Color Sampler (Syringe) tool to click on

the color you want to use. You can also select a color

while painting by holding down the Alt key and

clicking on the color.

Color Depth

You may edit icons having up to 16-million colors.

This will give you the smoothest gradients and

blended areas.

However, because some versions of Windows have

problems with icons which contain more than 256

colors, you will usually want to convert your final

icon to either 16 colors or 256 colors before saving

it. You can change the number of colors in the icon

by going to the Options menu and choosing the

Color Depth function.

Editing the Palette

For images containing 16 or 256 colors, you can

control the colors in the palette by going to the

Options menu and selecting Set Palette. You may

also adjust a single color by double-clicking on that

color in the palette.

The Set Palette screen allows you to adjust the colors

by sliding the control bars until you achieve the

Palette: Icon Color Depth at 16-million Colors
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shade you wish. You can also save the current palette

of colors , or load a previously saved palette.

IconForge will automatically adjust your image to

reflect the new colors.

Æ

Notes: There are 16 colors which Windows considers

“standard” and which we recommend that you use

when creating either 16 color or 256 color icons. You

may add these standard colors to your palette by

checkmarking the Use Windows default 16 colors

option.

Also note that if the user’s system is set to display either

16 or 256 colors, then Windows will only display your

icons using 16 colors (if your icon contains 256 colors,

then Windows will reduce the number of colors in order

to display it). If the user’s system is configured in a High

Color or True Color mode, then the full 256 colors will

be displayed.

See the following chapter for information about creating

icons which contain multiple images, so that Windows

can select the best icon for the user’s settings.

Change Colors / Load Palette
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Testing the Icon or Cursor

E ac h e d i t i ng w in d ow c on ta in s a Test b u t ton

(binoculars) located below the magnification

control. Clicking  this button  will display a box in

which you can move your icon or cursor over various

backgrounds, click controls (to test a cursor’s Hot

Spot), etc. To load a custom background, use the

folder button at the top of the Background Image

panel.

Saving Your Work

If you are editing an existing image, use the Save

option from the File menu.

For a new icon or cursor, click the File menu and

choose the Save As function from the list. You will

then be asked to specify a file name for the new

image. Use the File Type drop-down list to select the

type of image to save (this will add the correct 3-

letter extension to the file name).

Æ

Notes: You may also choose a file name from the list if

you would like to overwrite an existing file with the new
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image. A message will be displayed which will ask you

to confirm that you want the old image file to be

replaced with the new material.

If you are using the standard Windows-style File Selector

(this option is found under the File menu), you will need

to type in the 3-letter extension manually.
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