
Chapter 5

Importing/Exporting

Importing an Existing Image

Importing an Animation

Exporting to another File Format

Inserting Icons into Program Files

Creating Icon Libraries

Creating a .DLL for Icons or Cursors

You may use IconForge to import icons from within

program files, image files, other icon formats,

animation files, screen capture, scanned images, etc.

Importing an Existing Image

Importing from an Image File

You may import bitmap image files created in paint

programs, image editors, scanner software, etc. Use

the Open command from the File menu and select

the Type of file containing the image to be imported.

The image from the file you’ve selected is shown in

the large preview panel. A dotted selector box shows

the portion of the image which will be used for the

i c on (see illustration next page). I f y o u h a v e

selected an animation, a control bar will be placed
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beneath the image to allow you to scroll through and

select from the frames within the image (you can

select from a single frame or multiple frames, and

use the “+” button to place the frames into another

animation which is being edited).

If the image in the file which you wish to import is

other than one of the standard sizes used for

Windows icons and cursors, you will be given the

option to either scale the image to a standard size,

or to clip a portion from the larger image.

Set the size using the Icon Size drop-down list. To

scale the image to the size you’ve selected, enable

the Scale Image to Fit option. You may also choose

the number of colors which will be contained in the

image by clicking on the Icon Colors drop-down list.

To clip out an icon-sized area from the larger image,

set the Icon Size from the drop-down, but do not

check the Scale Image to Fit option. Then use your

Import Options
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mouse to drag the selection frame to that portion of

the image which you wish to use as an icon or cursor.

If you wish to use the standard Windows 16 color

palette for the image (recommended for most

Windows uses), check the Use Windows default 16

color palette checkbox.

If you have already loaded an Animation, Multi-

resolution Icon or Icon Library, you can also add the

imported image directly to those editing windows.

To select a file, select the filename from the drop-

down list box, then click on the “+” button (see also

the Importing an Animation topic which follows).

Use the Effects button to apply a special effect filter

to the image before importing it. If you wish to save

the entire image file once you’ve applied an Effects

filter, click on the Export button (e.g., if you wish to

save the altered image before it is resized and

imported into IconForge).

Acquiring from Resources

You may use the File menu’s Aquire from Resource

option to extract icons, cursors and other graphics

from a program file’s internal resources. These

functions will work with most programs, but there

are some instances where items may not be readable,

par t i cu la r l y when the program f i le i s h igh ly

compressed or in an older file format. In these

instances, either extract icons directly using the

Open function from the File menu, or run the pro-

gram and do a screen capture (see following topic).

The images found within the program will be listed

in the panel on the left side of the window. You may

click on various folders, and any images will be

displayed in the preview panel on the right.
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To choose another program file, click the Reload

button.

Once  you  find  an  image  which  you like,  click the

Extract button. The image will be loaded into the

image import window, where you may either import

it into IconForge for editing as an icon or cursor, or

where you may use the Export or Edit buttons to save

the image without turning it into an icon or cursor

(e.g., if you extract a large image which you do not

wish to reduce to icon size).

As always, please respect the rights of the owners of

any images you find. You should assume that these

images are protected under Copyright laws and

treaties. Avoid plagiarism of works by others, unless

you have written permission to use the image(s) or

should you know that the program is in the public

domain. When in doubt, contact the program’s

author.

Æ

Note: You cannot use this function to write images back

into programs.
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Grabbing Icons from the Screen

To capture an icon from your screen, first go to the

screen containing the icon which you want. Next,

run IconForge and go to its File menu. Select New,

and then From Screen Capture.

The screen behind IconForge will be loaded into the

image import window, and you will be able to select

the portion of the screen to use for your new icon or

cursor.

Importing an Animation

To import an existing animation from your system,

go to the File menu and select the Open function.

Select an animation file from your system (e.g., an

animated .gif). Click the Show Preview option at the

bottom of the screen to allow you to view the images

contained in the files. Once you have selected your

animation file, click the OK button.

The animation images will be loaded into the image

impor t window, which conta ins contro ls for

determining which portions of the animation will be

imported. In the Preview area, drag the dotted

selection box to surround the portion of the image

which you wish to use in creating your animation.

Y o u c a n m o v e th e s e l e c t i o n i n s i n g l e - p i xe l

increments by clicking the Nudge arrows on the

panel to the right of the Preview area.

You may click through the animation’s frames using

the VCR-style buttons just below the Preview area.

The number of the currently viewed frame is

displayed at the right side of this bar. You may

reduce the number of frames in the animation by

increasing the number in the field (e.g., “1" will
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import each frame in the animation, ”2" will import

every second frame, “3" will import every third

frame, etc.).

Once you are satisfied with your choices, either click

the OK button to load the currently selected frame

into the editor, or click the green + arrow below the

Preview area to load the selected frames into a new

animation editing window.

Resolution Options

You may further define the image to import by using

the following controls:

1 Scale Image to Fit: Checkmark this option to shrink

(or expand) the image to fit the dimensions specified

in the Size box (see below).

1 Icon Size: Currently, Windows only supports a size of

32x32 for displaying .ANI format images. If you wish

to make an animation with a different size, use the

included ImageForge program to create the animation

in the .AVI format.

1 Icon Colors: Use this option to choose the Color Depth

for the animation which you will be editing. Usually,

the images you will be producing will contain either

16 and/or 256 colors, but you may wish to import at a

higher resolution for editing purposes. You may

always change the Color Depth in the editor itself.

1 Include Windows 16 Colors: Use this option to insert

the standard 16 Windows colors into the animation’s

color palette (recommended).

1 Save Icon as a Frame: If you currently are editing an

animation (or a multi-resoluton icon) in IconForge,

you can add the selected image or animation frame

directly to an open editing window by choosing the

window’s title from the drop-down list, and then

clicking the green + button.
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Exporting to another File Format

To export an image to a non-icon format, use the

Save As function under the File menu.

If you know the three-letter filename extension for

the format you wish to export, you can simply type

in the full filename in the File Name field. The three

letter extension for supported image formats will be

automatically recognized and the file exported

(note: you must use this method if you are using the

standard Windows-style File Selector option under

the File menu).

If you wish, you may also simply choose a format

from the File Type field at the bottom of the Save As

dialog. Click on the arrow at the right side of the

field to display file format choices. The three letter

extension for the format you select will be automat-

ically added to the name in the File Name field

(Enhanced-style File Selector only).

If you wish to change the formats for a group of files

at once (e.g., from .ICO to .GIF), go to the File menu
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and select Group Conversion. Use the Add button to

select the images to convert. Select a folder and

format from the options below. If converting to an

icon or cursor, you may also specify the size for the

new icons/cursors. Click the Convert button to write

out the images in the new format.

Inserting Icons into Program Files

When you import an icon from EXE, DRV, SKL, VBX, DBX,
OCX, SKL, CPL or DLL program files using the Open

function from the File menu, IconForge will attempt

to save it back into the program file when you use

the Save command. IconForge will give you an

opportunity to abort the Save process when editing

an icon from within an EXE file. When editing a

program file, you should normally use the Save As

function to save the file as an ICO or other file format,

instead of using Save. If you wish to attempt to

replace the icon within a program, you should only

work on a COPY of the program file, and not the

original file. Replacing a programs icon can cause

that program to become unstable or  unusable. In

addition, it is often a violation of a programs license

agreement to alter its icon or other items of its

appearance. And some programs simply do not allow

such alterations and will no longer function, so

exercise caution. E.g., changing the logo icon for the

Windows NT4 Start button (which is contained in

the USER.EXE file) will cause an error message to be

displayed when you boot into NT.

Æ

Notes: Windows sometimes refuses to update its

settings unless you restart your system. If this occurs, go

to the Edit menu and select the Rebuild Icon Cache

option. Sometimes, more than one reboot is necessary

before all items are rewritten. When rebooting, use the

normal shutdown method, and not a Fast Shutdown

method.
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Creating Icon Libraries

IconForge allows you to produce several types of

Libraries to contain your files. Use Icon Library

format files (.ICL) to contain groups of static icons

which can be called by the Windows desktop or other

programs. Use Cursor Library format files (.CUL) to

hold static cursors for use in programming projects

(much like a .DLL file). You can also create stand-

alone EXE Library programs to hold and install your

images without the need for additional software.

ICL and CUL Library Files

The Library window for creating and editing .ICL and

.CUL format files contains a large display area, with

controls arrayed along the top of the window. Select

icons or cursors from within the library by using the

scroll bar on the window’s left side to move through

the collection, then click on the desired image.

Once an image is selected, it may be edited,

dupl icated, deleted or reposit ioned to a new

location within the library using the controls. The

bar at the top of the screen also displays the size and

color depth of the currently selected icon. You may

also specify a title for the selected image by typing

text into the field on the right side of the bar.

Icon / Cursor Library Window
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.ICL Library files are often used to group your icons

into a convenient form. This can save space on some

systems and can also make it easier to move a group

of icons from one system to another. Some artists

and publ ishers se l l profess ional qual i ty icon

collections in ICL format. Another use for Icon

Libraries is for programming projects in which all the

icons in an application are stored in a  single ICL

(normally, the Windows API ExtractIcon call is used

to locate the icon within the file).

Stand-alone EXE Libraries

Stand-alone EXE Libraries may also be created from

the Library menu selection. You may use this

function to create a simple installation program to

place your files onto a user’s disk. To do this, do not

checkmark the Place All Icons Listed Within an Icon

Viewer Program option. Instead, simply click on the
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“+” button to create a list of the files to be installed.

The Installation File Name field allows you to assign

a filename to your install program.

Use the Installation File Size field to specify the

maximum size of the media used to distribute the

compressed Library. E.g., if you are using 1.44 MB

diskettes, you might type 1448960 (the number of

bytes which a 1.44 MB diskette can contain). If the

Library is larger than the value specified here, the

files will be split into pieces which may be placed on

separate diskettes. The filenames for each piece will

end in a numeral to denote the disk order (e.g., for

a 3 disk set: sample.001 would go onto the first disk,

sample.002 would go on disk 2, and sample 003

would go onto the last disk). Be sure to label the

media so that the user knows which diskette to insert

when the installation program requests a disk.
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If you place all the pieces on a single drive directory

folder capable of holding them, the user will not be

prompted to swap disks. This means that you can

usually place the same set of files on both multiple

diskettes and on a single CD-ROM disc.

You may also click on the Installation Appearance

tab to set colors and a title for your install program.

You can produce a more sophisticated stand-alone

Library program if you checkmark the Place All

Icons Listed Within an Icon Viewer Program

option. When you do this, an Icon Viewer tab will

appear at the top of the window. All selected files

will be written into a viewing program, which is

copied to the user’s disk by the installation program.
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The Icon Viewer tab allows you to specify the name

of the viewing program, and other information used

in the viewing program’s window.

You may select whether to allow users to export

images from the viewer (do not checkmark this

option if you only want users to view, and not use,

the files), whether to allow users to print the images,

and whether to include a copy of the ActivIcons

utility with the viewer so that users may change their

various Windows system icons and cursors.

Once you have created a list of files and configured

the settings for your Library, click on the Create

button to begin building the program. The files will

be compressed, and if the end result is larger than

the size specified in the Library File Size field on the

Icon Files tab (e.g., if you are placing on diskettes),

then the program will automatically be split into

sections. Once the program has been created, then

it is simply a matter of placing the program on

diskettes or other media. If several pieces were

created, then place each piece on a diskette which

has been labeled to indicate which piece resides on

the diskette:

E.g., If your Setup program is split into 3 sections:

SETUP.EXE and SETUP.001 would go on Disk 1 of 3

SETUP.002 would be placed on Disk 2 of 3

SETUP.003 would be placed on Disk 3 of 3

When users run the SETUP.EXE program to install

your library, they will be prompted to insert each

diskette in turn.

Æ

Note: If you develop lists of icons, color schemes and

other settings that you may want to use again, use the

Save button to save the current setup. Use the Load

button to load previously Saved settings. The Clear
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button is a quick way to clear the list of files on the Icon

Files tab.

Using an Icon Library as a .DLL

You may also convert ICL or CUL Icon/Cursor Library

files into a DLL type files, simply by renaming their

three-letter filename extensions to “.DLL”

As a .DLL, you can access the icons directly from

Windows and other programs. Programmers may

also access icons from within .ICL, .CUL or .DLL files

using the Windows ExtractIcon and/or LoadImage

API’s.

Æ

Note that most .DLL’s contain programming material

in addition to icons and cursors. To edit an existing

.DLL, use the Open command from the File menu and

edit individual icons directly. You cannot add, subtract

or change the resolution of icons within a .DLL or other

program file, since this would risk corrupting the file.

If you know that a .DLL contains only icons (i.e., it

is a .DLL which you originally created as an .ICL or

.CUL), then you can rename its filename extension

back to .ICL and edit it using the Library menu’s

functions.
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