
Chapter 7

Frequent Questions

Animation Missing

Q When I create an ANI animation and place it on my

desktop, I only see a stationary image. How can I make

use of my ANI files?

A Unfortunately, the default Windows desktop does not

support using ANI images. The desktop only displays the

first frame of an ANI. However in Windows 95 and later

versions, you may use your animations as cursors by

going to the Control Panel and setting up the cursors

under the Mouse functions.

The ActivIcons utility included with IconForge (choose

the Change Windows Shell Icons from the Edit window)

will allow some systems to animate various desktop

icons. You must run the ActivIcons utility in the Windows

Task Bar’s “Tray” for the icons to animate, however.

CursorArts Company also publishes the SecurDesk! and

SecurDesk! LV programs (which may be downloaded

from our site). These applications allow you to replace

the Windows desktop and let you use animated icons on

both its desktop, and as “mouse-overs” (i.e., the cursor

animates when it travels over certain buttons or hot spots

on the desktop). There are other programs (databases,

programming languages, etc.) on the market which also

allow use of ANI files.
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Bad Icon

Q I have an ICO file which appears on my desktop, but

when I open it in IconForge, I only get random dots and

lines. How can I edit this icon?

A The problem with this image is that it is not a standard

icon file. Later versions of Windows may be able to display

this type of image on the desktop, but other versions of

Windows, and many other programs, will not.

The image that you suppose is an icon is probably simply

a BMP or other format image which has been renamed

with an ICO extension. BMP format images which have

been renamed with an ICO extension are not true icon

images, even though some people use them as such

(some Windows versions can be configured to display

iconized version of BMP images, and these will show any

BMP file as an icon, although doing this can dramatically

slow down display of file listings).

To import this image into IconForge, you must first

rename the file to have a “.BMP” filename extension

(instead of the “.ICO” extension). Next, use the Open

command under the File menu to import the image.

No Transparency

Q The transparent color in my icon does not become

transparent when I place the icon on the desktop. How

do I get portions of the icon to be transparent?

A You are probably confusing the transparent preview

color (which is set using the Options/Set

Preferences/Trans Color function) with transparency.

The transparent preview color allows you to see how

your icon will appear against different colored

backgrounds. Icons allow you to use all of the colors on
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the palette, and there is no actual “color” to transparent

areas in these images.

To paint with transparency, you should click on the

palette  selection containing  a dot  in the  center (see

illustration above). All pixels containing transparent

paint contain a small dot in their centers (although these

may not display well with some preview background

colors on some systems). If you change the transparent

preview color (using Options/Set Preferences/Trans

Color), these pixels will use the new color background.

Making Favorites Icons Permanent

Q My Favorites icons disappear from my Internet Explorer

list. What happened?

A Internet Explorer stores its Favorites icons in its

Temporary Internet Files folders. These folders are a

cache, and material begins to be automatically deleted

from these folders as they begin to fill up their allotted

space. However, you can make your icons permanent

with a couple of steps:

Step 1. In IconForge, go to the File menu and choose the

Open Favorites Icon from URL Site option and type in the

Internet site location to load the icon for that site. Once

the icon is loaded, use Save As to save it onto your drive

(put in into any folder other than those within the

Temporary Internet Files cache, however);

Step 2. In ActivIcons, go to the Internet Favorites screen

and select the shortcut in the list. Click the Change Icon

button to specify the icon which you just loaded / saved.

Transparent Paint

Tool Bar
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Note that if you want to specify your own icon creation

for a Favorite shortcut, you can just use Step 2. You do

not necessarily need to use the icon from the Web site.

Slow Display

Q My icons display very slowly in Explorer, particularly if I

go to a folder which contains pictures.

A If you are displaying icons showing the contents of your

picture files, then this can slow down Explorer consider-

ably (particularly when it encounters very large images).

To fix this, go to the Edit menu and choose Change

Windows System Icons to run the ActivIcons utility. Click

down to the Interface screen and turn off the Display a

picture of the bitmap (BMP) in all file lists option.

Some graphics software packages also display iconized

previews of images. If you have such software, then you

may need to turn this feature off inside that program.

Make Cursor More Apparent

Q My pointer gets lost on some light-colored backgrounds.

Is there a way to change the pointer depending on the

background color?

A Here are a couple of techniques which may help you:

1. Outline your light-colored cursor using a dark outline

(e.g., the default Windows pointers use this technique).

2. Paint portions of your cursor using the Inverse color

(this is located just under the Transparent paint button

on the palette). The Inverse portions of your pointer will

reverse any colors over which it passes (e.g., White will

become Black, Light Cyan will become Red-Orange, Blue

will be shown as Yellow, etc.). The contrast will make
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your pointer more apparent over most areas. However,

your pointer should  not depend entirely on Inverse

paint, since the Inverse of some shades of medium grey

can still be difficult to detect. Use the Test (the binoculars

icon) button on the editing window to view your pointer

against a variety of backgrounds.

Corrupt Desktop Icon Display

Q When my icon displays on the desktop, it has lines or

spots on it, and it looks terrible.

A It sounds as though your icon is a non-standard size. If

your icon is a size other than that specified in the

Windows display settings, then Windows will attempt to

stretch your icon to fit (and it frequently does a terrible

job of it). You can check your Windows default icon

setting by right-clicking an empty area on your desktop,

then choosing Properties, going to the Appearance tab

and selecting Icon from the Item list.

The most frequently encountered standard sizes for

Windows icons are 16x16, 32x32, 48x48 and 64x64. You

can avoid having Windows stretch your icon by creating

a Multi-Resolution Icon which contains all of these sizes

(or at least the 16x16 and 32x32 sizes). See Chapter 3 for

more information regarding Multi-Resolution icons.

Favorites Icon Shows Incorrectly

Q I placed my Favorites icon onto my site, but when I view

it in Internet Explorer, it is warped and doesn’t show

the correct colors. I tried putting another copy on the

server, but now it doesn’t appear at all?

A Be sure to upload the file to your web site in Binary

mode. Some FTP and file transfer programs do not

recognize the .ICO file format by default and will instead
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upload the icon file in ASCII format (which will corrupt

the file).

Blurry Icon

Q I imported a larger graphic and it seems very blurry in

the icon size. Is there a way to import a sharper icon?

A When reducing the size, IconForge attempts to preserve

as much detail as possible, which can result in a blurred

appearance. To correct this, try going to the Effects menu

and applying the Sharpen and/or Detail filters to the

imported icon. Usually, these will make the icon look

much clearer at the reduced size.

Alternatively, you can sharpen the image prior to

importing it. After you select the image to import, it will

be loaded into the Import Options window. This window

has an Effects button which will allow you to apply filters

prior to importing the image or screen capture. Note that

if you like the results of the filter, you can also save the

results of the Effects filter back into the original image by

clicking the Export button.

Wrong Colors

Q I have noticed that some systems display my icon with a

grey appearance, or using the wrong colors. They look

fine on my own system and in IconForge, however. Is

there something wrong with my icon, or if not, is there

a way to avoid having this happen when the icon is

displayed on other systems?

A There are a few possible causes for this behavior:

If the Windows Display settings are set to 16 colors or

256 colors, Windows will reduce the number of colors in

your icon to 16 — and not always with attractive results.
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To avoid this, use a Multi-Resolution Icon which contains

both 16-colors and 256-colors versions of your icon (see

Chapter 3 for more information).

If you cannot use a Multi-Resolution Icon, you may be

better off either using a 16-color icon which contains only

the 16 default Windows colors. To reduce your icon to

the default 16 colors, go to the Options menu and choose

Color Depth. Selecting the 16 Dithered Windows Colors

option usually produces the most pleasing result.

Another problem which can occur is that some versions

of Windows do not correctly display icons which contain

more than 256 colors (e.g., Windows NT and 2000).

Converting your icon down to 256 colors will solve this,

with very little loss of image quality. Go to the Options

menu and select Color Depth to reduce the number of

colors. Note that if you are using a Multi-Resolution Icon,

you should also remove any 16-million color icons from

this as well, since these Windows versions will still

attempt to display 16-million color icons, even though

they cannot correctly do so.

Cannot Run Program with New Icon

Q I have changed the icon for an .EXE program using

IconForge. When I attempt to run the program, it will

no longer run. Why?

A Some programs do not allow their icons to be changed

(this also applies to other program files, such as .DLL’s).

This is why we recommend making a backup for any

program file you attempt to edit.

However, the most likely reason you cannot run the

program is that you used the Save As command instead

of the Save command when saving your icon. You must

use the Save command to write your icon back into the

program file. Using Save As writes out a new file, and may
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not contain all  of the information necessary for the

program to execute.

Files without Icons

Q I have a couple of programs which do not display any

icon. How can I place an icon into these files?

A Generally, you cannot insert an icon into an existing

program or document unless it already contains icon

resources. However, you may be able to use the

IconForge Wrapper utility (found under the Tools menu).

This places the file into a small program which extracts

and launches your file whenever someone chooses to run

it. Because the file will be encapsulated in a program

which contains an icon, you are able to specify an icon

for the program produced by the wrapper.

You must specify the File to Wrap (just click on the arrow

icon at the right side of the field). Choose a 32x32 icon.

If you are wrapping a

document, image, or

other non-program

file, f i l l in the

Application used to

Execute f ie ld and

specify the command

line for the program

which views or edits

your file. Leave this

f ield blank for

programs and scripts, or if you wish Windows to use the

application associated with this type of document.

Specify a filename for the new program using the Name

of file produced field. If you want the extracted file to be

deleted by the program after it has been run, checkmark

the Delete File when finished option.

54 - Frequent Questions


